PCに4Kディスプレイを導入したら、マザボから何からほぼ買い替えに

公開日:

自宅のメインPCに4Kディスプレイを導入しました。といっても大きなモニターで動画を見たいとかいうのではなく、モバイル端末でのRetinaディスプレイの普及に際し、ウェブサイト制作を本職とする人間として、PCでもRetina環境を整えておきたいという理由です。

なので、ディスプレイは24型の小さいやつで、当然この大きさで解像度 3840×2160 を表示するとまともに文字が読めないので、OSの機能で200%に拡大する使い方です。

Dell から5万円ちょっとで買えるモニターが出ているので、それを購入しました。

ところで、これまでのマシンは2009年ころにBTOで構築したものでした。CPUは Core i7 の第1世代(Nehalem)を積むなど当時としてはそこそこ高性能な装備を備えており、またメモリやHDDは増設しているため、性能に不満はないのですが、いかんせんインターフェースが陳腐化しており、PCの主要パーツのほとんどを買い替える羽目になってしまいました。結論から言うと、こんな感じに構成が変わっています。

マザーボード
RENAISSANCE Ⅱ → Z170A GAMING PRO
CPU
Core i7-920(2.66GHz) → Core i7-6700(3.4GHz)
メモリ
DDR3 9GB(1GB × 3 + 2GB × 3) → DDR4 16GB(8GB × 2)
グラフィックボード
GeForce 9600 GT → GeForce GTX 960

グラフィックボード

PCで4Kを出力するには HDMI か Display Port 1.2 での接続が必要になるようです。さらに HDMI の場合、4Kでリフレッシュレート60Hzで表示するには HDMI 2.0 が必要とのこと。元のグラボには HDMI どころか DVI-I 端子しかないため、買い換えないといけません。

3Dゲームをすることはないため、そこまで高性能なものは必要ないのですが、将来的に4Kかつデュアルディスプレイの可能性を考えると、 Display Port 1.2 か HDMI 2.0 端子が2つあることが望ましいので、その要件を満たすGeForce GTX 960(www.nvidia.co.jp)を購入しました。

マザーボード

ところが、グラボを換装したらOSがまともに動作しなくなってしまいました。電源を入れてからデスクトップ画面になるまで1時間くらいかかり、その後もCPU使用率が常に100%になっていて、なにをするにも異様に時間がかかる始末。BIOSを最新にするなど、いろいろ設定変更をしてもダメで、一方でそのグラボを別マシンに挿すと正常に動いたので、グラボ自体の初期不良というわけではなさそうです。

結局のところ、新型グラボと旧型マザーボード(FOXCONN の RENAISSANCE Ⅱ)との相性が悪いのだと思われ、マザボも買い換え。

フォームファクタは今までと同じATXで、CPUソケットの規格が希望するCPUに合うことはもちろんですが、 PCI Express 3.0 の数も重要です。現状、グラボで x16 を1つ、TVチューナーとオーディオ出力で x1 を2つ使っており、将来の増設を見越してそれぞれ1つずつは余裕があったほうがいいなということで、 x16 と x1 がそれぞれ3つ付いているMSI の Z170A GAMING PRO(jp.msi.com)を購入。

CPU

元の Core i7-920(2.66GHz)で大きな不満はないため、現行 Core i7 の中でいちばん安価なやつ(6700・3.4GHz)か、あるいは Core i5 に落としてもいいかなと思ったのですが、 i5 と i7 の実売価格差が1万円程度だったこともあり、長く使うことを考え i7 に。

メモリ

元々差していたのは DDR3 タイプで、現行の DDR4 とは互換性がないため、メモリも買い換え。

容量は 4GB × 2 か 8GB × 2 かで少し迷い。スロット数には余裕があるので、とりあえず 4GB × 2 を買っておいて、必要になった時点で増強してもよかったのですが、1GB単価は 8GB × 2 の方が安いので、そちらを購入しました。

メーカーなどは吟味したわけではなく、たまたま行った店に在庫があった中から選択。

ソフトウェア

Windows 7 を無料アップグレード期間に Windows 10 にしていました。構成を一気に変更したため、クリーンインストールも覚悟していたのですが、何事もなく起動したのでそのままで。ただドライバーのインストールなどちょっとした作業は発生しました。

  • Windows のライセンス認証が外れていたので、「システム」→「プロダクト キーの変更」から、 Windows 7 パッケージに貼られていたプロダクトキーを入力
  • インターネット接続とスピーカーが認識されなかったので、マザボの付録CD-ROMからネットワークドライバーとサウンドドライバーをインストール
  • グラボのドライバは自動インストールされたが、バージョンが古かったので、メーカーのサイトから最新バージョンをダウンロードしてインストール

費用

これは主に自分用メモですが。大きな買い物なので秋葉原で見て回りたかったのですが、休日になかなか時間がとれず、ヨドバシカメラのネット通販と地元のパソコンショップを使いました。

  • ディスプレイ(Dell P2415Q-C) ¥55,900(10%ポイント還元)
  • グラフィックボード(玄人志向 GF-GTX960-E4GB) ¥24,220(10%ポイント還元)
  • マザーボード(MSI Z170A GAMING PRO) ¥17,000
  • CPU(Core i7-6700) ¥35,000
  • メモリ(Crucial CT2K8G4DFS8213 8GB×2) ¥12,000

しめて14万4120円なり。

というわけで、グラボだけ買えばいいかなと思っていたらとんだ大事になってしまいましたとさ。

しかし考えてみれば、2009年に構築した環境をHDDやメモリ増設はしたにせよ、根幹部分は変えずに7年半使い続けてきたわけで、いい機会だったのかもしれません。'90年代とか、同じマシンを7年半使い続けるとか考えられなかったなあ……(遠い目)。はたして今回の構成は何年持つのやら。